jenkins-updates.cloudbees.com having issues

Incident Report for CloudBees

Resolved

The issue has been identified and fixed. The service is now fully operational
Posted May 10, 2020 - 20:00 UTC

Investigating

Currently investigating https://jenkins-updates.cloudbees.com returning 401s when downloading plugins.
Posted May 10, 2020 - 17:59 UTC